The Linux Foundation

 
Accessibility/News/2011/02/01/AT-SPI2 release 1.91.6.1

From The Linux Foundation

Contents

AT-SPI2 1.91.6.1 Released

release date: 2011-02-01

What is AT-SPI2 1.91.6.1?

AT-SPI2 is a D-Bus based accessibility framework. It defines a D-Bus protocol for providing and accessing application accessibility information. The project includes a library for bridging the D-Bus protocol to the ATK API, allowing Gtk based applications to be made accessible. It also contains a client (AT) side library in Python.

AT-SPI5 1.91.6.1 is now available for download at:

Note: at-spi2-core 1.91.6 contained a crash introduced with a last-minute API addition, so there is a 1.91.6.1 with a fix for that and another issue.

AT-SPI2 1.91.6.1 Release Notes

A list of work required before the full release can be found at:

http://www.a11y.org/d-bus

What's changed in AT-SPI2 1.91.6.1?

  • [all] Added setters for component extents/size/position.
  • [atk] Fixed the path in org.a11y.atspi.gschema.xml for lib64.
  • [core] Some build fixes.
  • [core] Added a method to check whether an object implements the Hyperlink interface.
  • [core] Fixed a crash in atspi_image_get_image_description.
  • [core] Fixed atspi_editable_text_set_text_contents.
  • [core] More error-handling fixes.
  • [core] Fixed a crash in atspi_event_listener_register_from_callback.
  • [core] Method calls now time out after 1 second.
  • [core/atk] Several updated translations.
  • [core/pyatspi] Added atspi_accessible_set_cache_mask.
  • [pyatspi] Added source_name and source_role to events.
  • [pyatspi] Call gconftool-2 to check the value of /desktop/gnome/interface/at-spi-corba rather than importing gconf, since the latter can cause problems if new and old versions of the Python bindings are mixed.

Where can I get more information about AT-SPI2?

The project wiki is available at:

http://www.a11y.org/d-bus


How can I contribute to AT-SPI2?

We are actively seeking contributors to help us make this the standard a11y framework for Gnome. We need help testing with Gnome accessibility technologies, improving performance, and generally tying up loose ends. The above-referenced page contains a list of known issues that should be fixed.

To participate in AT-SPI2 development, you can:

Development repositories for AT-SPI2 can be found at:





[Article] [Discussion] [View source] [History]